What’s Vulnerable › Vulnerabilities
CVE-2026-41487: Langfuse: Improper role-based-access control in Langfuse LLM connection management allowed users of role “member” to retrieve stored LLM provider API keys
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-284
Description
Langfuse is an open source large language model engineering platform. From version 3.68.0 to before version 3.167.0, there is a role-based-access control flaw in the LLM connection update flow. An authenticated, low-privileged user of role “member” in a project could request the update of an existing LLM connection to an attacker-controlled baseUrl, causing Langfuse to reuse the stored provider secret and redirect the test request to an attacker-controlled endpoint. This could expose the plaintext provider LLM API key for that connection. The attack is only possible if a user is already part of a project and has “member” scoped access. This issue has been patched in version 3.167.0.
Affected products
- langfuse: from 3.68.0 before 3.167.0 — fixed in 3.167.0
How to fix
Upgrade to a fixed version: langfuse 3.167.0. Check the vendor advisory for mitigations.
References
- https://github.com/langfuse/langfuse/commit/7527bb0d84bc0a3dc24a4b16d22ed2e46e6dddff
- https://github.com/langfuse/langfuse/commit/e12386f9d4368bbfff24a4ad7fd53641091605ff
- https://github.com/langfuse/langfuse/pull/13027
- https://github.com/langfuse/langfuse/pull/13055
- https://github.com/langfuse/langfuse/releases/tag/v3.167.0
- https://github.com/langfuse/langfuse/security/advisories/GHSA-2524-j966-gfgh
Get alerted when CVE-2026-41487 or the next vulnerability affects your stack