What’s Vulnerable › Vulnerabilities
CVE-2026-41493: yard: Possible arbitrary path traversal and file access via yard server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-22
Description
YARD is a Ruby Documentation tool. Prior to version 0.9.42, a path traversal vulnerability was discovered in YARD when using yard server to serve documentation. This bug would allow unsanitized HTTP requests to access arbitrary files on the machine of a yard server host under certain conditions. This issue has been patched in version 0.9.42.
Affected products
- lsegal yard: before 0.9.42 — fixed in 0.9.42
How to fix
Upgrade to a fixed version: lsegal yard 0.9.42. Check the vendor advisory for mitigations.
References
- https://github.com/lsegal/yard/releases/tag/v0.9.42
- https://github.com/lsegal/yard/security/advisories/GHSA-3jfp-46x4-xgfj
Get alerted when CVE-2026-41493 or the next vulnerability affects your stack