What’s Vulnerable › Vulnerabilities
CVE-2026-41501: electerm has Command Injection Vulnerability via runLinux function
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-77
Description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.
Affected products
- electerm: before 3.3.8 — fixed in 3.3.8
How to fix
Upgrade to a fixed version: electerm 3.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128ee
- https://github.com/electerm/electerm/releases/tag/v3.3.8
- https://github.com/electerm/electerm/security/advisories/GHSA-8x35-hph8-37hq
Get alerted when CVE-2026-41501 or the next vulnerability affects your stack