What’s Vulnerable › Vulnerabilities
CVE-2026-41521: xrdp: lib_framebuffer_update Has Integer Overflow Heap Info Leak & ASLR Bypass
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-10-24
- Weakness: CWE-190
Description
xrdp is an open source RDP server. Versions 0.10.6 and prior contain an integer overflow vulnerability when processing screen update messages within the vnc-any connection mode. A malicious remote VNC server can send crafted image dimensions that cause an integer overflow during memory buffer size calculation, resulting in an undersized allocation. Subsequent processing of the incoming image data using the original oversized parameters leads to an out-of-bounds read. An unauthenticated remote attacker could exploit this flaw to disclose sensitive information from the heap memory or cause a denial of service (DoS) via a process crash. This issue has been fixed in version 0.10.6.1.
Affected products
- neutrinolabs xrdp: before 0.10.6.1 — fixed in 0.10.6.1
How to fix
Upgrade to a fixed version: neutrinolabs xrdp 0.10.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/neutrinolabs/xrdp/releases/tag/v0.10.6.1
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-v8w6-pf78-9458
Get alerted when CVE-2026-41521 or the next vulnerability affects your stack