What’s Vulnerable › Vulnerabilities
CVE-2026-41566: Apache Kvrocks: Improper permission for the APPLYBATCH command
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-280
Description
Improper Handling of Insufficient Permissions or Privileges vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: 2.8.0. Users are recommended to upgrade to version 2.16.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kvrocks: from 2.8.0 through 2.15.0
References
- https://lists.apache.org/thread/zng5lp7psgkcv9jnm9tztdlm3rmzfydl
- http://www.openwall.com/lists/oss-security/2026/06/25/1
Get alerted when CVE-2026-41566 or the next vulnerability affects your stack