What’s Vulnerable › Vulnerabilities
CVE-2026-41567: Docker: `PUT /containers/{id}/archive` executes container binary on the host
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-05 · updated 2026-09-09
- Weakness: CWE-427
Description
Moby is an open source container framework. In versions prior to 29.5.1 and in moby/moby v2 prior to v2.0.0-beta.14, when a compressed archive is uploaded to a container via `PUT /containers/{id}/archive` or piped through `docker cp -`, the daemon resolves decompression binaries (such as `xz` or `unpigz`) from the container's filesystem rather than the host's due to incorrect ordering of operations. A malicious container image containing a trojanized decompression binary can achieve arbitrary code execution with full daemon privileges, including host root UID and unrestricted capabilities, when a user uploads a compressed (xz or gzip) archive into that container. This issue is fixed in Docker Engine 29.5.1 and moby/moby v2.0.0-beta.14. Workarounds include only running containers from trusted images, using authorization plugins to restrict access to the `PUT /containers/{id}/archive` endpoint, and avoiding piping compressed archives into containers created from untrusted images
Affected products
- docker/daemon: through 28.5.2
- moby Docker Engine: before 29.5.1
- moby/v2/daemon: before 2.0.0-beta.14
References
- https://github.com/moby/moby/security/advisories/GHSA-x86f-5xw2-fm2r
- https://access.redhat.com/errata/RHSA-2026:37387
- https://access.redhat.com/errata/RHSA-2026:41030
- https://access.redhat.com/errata/RHSA-2026:42852
- https://access.redhat.com/errata/RHSA-2026:44622
- https://access.redhat.com/errata/RHSA-2026:51057
- https://access.redhat.com/security/cve/CVE-2026-41567
- https://bugzilla.redhat.com/show_bug.cgi?id=2485356
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41567.json
Get alerted when CVE-2026-41567 or the next vulnerability affects your stack