What’s Vulnerable › Vulnerabilities
CVE-2026-4157: ChargePoint Home Flex revssh Service Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-11 · updated 2026-10-26
- Weakness: CWE-78
Description
ChargePoint Home Flex revssh Service Command Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of ChargePoint Home Flex devices. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of OCPP messages. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-26338.
Affected products
- ChargePoint Home Flex: before 5.5.4.22 — fixed in 5.5.4.22
How to fix
Upgrade to a fixed version: ChargePoint Home Flex 5.5.4.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4157 or the next vulnerability affects your stack