What’s Vulnerable › Vulnerabilities
CVE-2026-41575: th30d4y/IP: DOM-Based Cross-Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
In th30d4y/IP from version 1.0.1 to before version 2.0.1, a DOM-Based Cross-Site Scripting (XSS) vulnerability was identified in an IP Reputation Checker application. Unsanitized user input was directly rendered in the browser, allowing attackers to execute arbitrary JavaScript. This issue has been patched in version 2.0.1.
Affected products
- th30d4y IP: from 1.0.1 before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: th30d4y IP 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41575 or the next vulnerability affects your stack