What’s Vulnerable › Vulnerabilities
CVE-2026-41608: Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-10-24
- Weakness: CWE-409
Description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.24.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9
- https://lists.apache.org/thread/vwsbcwqdpwdtp8qkjo11ol6rodbfm21f
- http://www.openwall.com/lists/oss-security/2026/07/24/32
Get alerted when CVE-2026-41608 or the next vulnerability affects your stack