What’s Vulnerable › Vulnerabilities
CVE-2026-41636: Apache Thrift: Node.js skip() recursion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-10-31
- Weakness: CWE-674
Description
Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.23.0 — fixed in 0.23.0
- Apache Software Foundation Apache Thrift: before 0.23.0 — fixed in 0.23.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.23.0; Apache Software Foundation Apache Thrift 0.23.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/lb4j0zyd5f3g36cos0wql925przpnwql
- http://www.openwall.com/lists/oss-security/2026/04/28/1
Get alerted when CVE-2026-41636 or the next vulnerability affects your stack