What’s Vulnerable › Vulnerabilities
CVE-2026-41643: GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-129
Description
GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.
Affected products
- osrg GoBGP: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: osrg GoBGP 4.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/osrg/gobgp/releases/tag/v4.3.0
- https://github.com/osrg/gobgp/security/advisories/GHSA-8rxh-r2p6-7f2q
- https://github.com/osrg/gobgp/security/advisories/GHSA-8rxh-r2p6-7f2q
Get alerted when CVE-2026-41643 or the next vulnerability affects your stack