What’s Vulnerable › Vulnerabilities
CVE-2026-41677: rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-06-17
- Weakness: CWE-125
Description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.
Affected products
- rust-openssl: from 0.9.0 before 0.10.78 — fixed in 0.10.78
How to fix
Upgrade to a fixed version: rust-openssl 0.10.78. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41677 or the next vulnerability affects your stack