What’s Vulnerable › Vulnerabilities
CVE-2026-41679: Paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 31.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-10-25
- Weakness: CWE-287
Description
Paperclip is a Node.js server and React UI that orchestrates a team of AI agents to run a business. Prior to version 2026.416.0, an unauthenticated attacker can achieve full remote code execution on any network-accessible Paperclip instance running in `authenticated` mode with default configuration. No user interaction, no credentials, just the target's address. The chain consists of six API calls. The attack is fully automated, requires no user interaction, and works against the default deployment configuration. Version 2026.416.0 patches the issue.
Affected products
- paperclipai @paperclipai/server: before 2026.416.0 — fixed in 2026.416.0
- Paperclipai/Server: before 2026.416.0 — fixed in 2026.416.0
How to fix
Upgrade to a fixed version: paperclipai @paperclipai/server 2026.416.0; Paperclipai/Server 2026.416.0. Check the vendor advisory for mitigations.
References
- https://github.com/paperclipai/paperclip/security/advisories/GHSA-68qg-g8mg-6pr7
- https://github.com/paperclipai/paperclip/security/advisories/GHSA-68qg-g8mg-6pr7
Get alerted when CVE-2026-41679 or the next vulnerability affects your stack