What’s Vulnerable › Vulnerabilities
CVE-2026-41692: i18nextify is vulnerable to DOM XSS via javascript:/data: URL schemes in translated href/src attributes
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-79
Description
i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 4.0.8 substitute {{key}} interpolation tokens inside src and href attribute values with the raw string returned by i18next.t(). The substitution logic in src/localize.js (the replaceInside handler) only guards against a duplicated http:// origin prefix — it does not validate the URL scheme of the substituted value. A translated value such as javascript:alert(1) or data:text/html,<script>...</script> is applied unchanged to the live DOM attribute when an attacker can influence the content of a translation file or the translation-backend response — for example, via a compromised translation CDN, user-contributed locales, a MITM on a plain-HTTP backend, or write access to the translation JSON. This issue was patched in version 4.0.8.
Affected products
- i18nextify: before 4.0.8 — fixed in 4.0.8
How to fix
Upgrade to a fixed version: i18nextify 4.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/i18next/i18nextify/commit/16f23dbcdcf893673587f7a03355bf7ce0a0e49e
- https://github.com/i18next/i18nextify/security/advisories/GHSA-6457-mxpq-4fqq
Get alerted when CVE-2026-41692 or the next vulnerability affects your stack