What’s Vulnerable › Vulnerabilities
CVE-2026-41699: Unsafe Deserialization in Spring GraphQL
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-07-23
- Weakness: CWE-502
Description
Spring for GraphQL applications are vulnerable to Unsafe Deserialization when processing paginated GraphQL queries. An attacker can craft a malicious GraphQL request that can lead to Remote Code Execution when the application exposes a paginated (Connection) field and the classpath contains specific classes that can be leveraged during deserialization. Affected versions: Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8.
Affected products
- Spring for GraphQL: from 1.3.0 before 1.3.9; from 1.4.0 before 1.4.5.1; from 2.0.0 before 2.0.3.1 — fixed in 1.3.9, 1.4.5.1, 2.0.3.1
- Spring for GraphQL: from 2.0.0 before 2.0.3.1; from 1.4.0 before 1.4.5.1; from 1.3.0 before 1.3.9 — fixed in 2.0.3.1, 1.4.5.1, 1.3.9
How to fix
Upgrade to a fixed version: Spring for GraphQL 1.3.9, 1.4.5.1, 2.0.3.1; Spring for GraphQL 2.0.3.1, 1.4.5.1, 1.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41699 or the next vulnerability affects your stack