What’s Vulnerable › Vulnerabilities

CVE-2026-41700: Cross-Site WebSocket Hijacking in Spring for GraphQL

Description

Spring for GraphQL applications that have enabled the WebSocket transport are vulnerable to Cross-Site WebSocket Hijacking. An attacker can trick an authenticated user into visiting a malicious page, allowing the attacker to execute arbitrary GraphQL operations with the victim's credentials. Affected versions: Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8; 1.0.0 through 1.0.6.

Affected products

How to fix

Upgrade to a fixed version: Spring for GraphQL 1.0.7, 1.3.9, 1.4.5.1, 2.0.3.1; Spring for GraphQL 2.0.3.1, 1.4.5.1, 1.3.9, 1.0.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41700 or the next vulnerability affects your stack