What’s Vulnerable › Vulnerabilities

CVE-2026-41705

Description

Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.

Affected products

How to fix

Upgrade to a fixed version: Spring AI 1.0.7, 1.1.6; Spring AI 1.0.7, 1.1.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41705 or the next vulnerability affects your stack