What’s Vulnerable › Vulnerabilities

CVE-2026-41711: Potential Denial of Service through crafted Sort Parameters

Description

Applications using Spring Data Commons may be vulnerable to a Denial of Service (DoS) attack leading to a StackOverflowException when parsing Sort parameters. Affected versions: Spring Data Commons 4.0.0 through 4.0.5; 3.5.0 through 3.5.11; 3.4.0 through 3.4.14; 3.3.0 through 3.3.16; 3.2.0 through 3.2.15; 3.1.0 through 3.1.14; 3.0.0 through 3.0.15; 2.7.0 through 2.7.19.

Affected products

How to fix

Upgrade to a fixed version: Spring Data Commons 2.7.20, 3.3.17, 3.4.15, 3.5.11.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41711 or the next vulnerability affects your stack