What’s Vulnerable › Vulnerabilities
CVE-2026-41712: ChatMemory DEFAULT_CONVERSATION_ID causes unintended cross-user data leakage
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-276
Description
Spring AI's chat memory component contained a problematic default that, when not explicitly overridden, could result in unintended data exposure between users.
Affected products
- Spring AI: from 1.0.0 before 1.0.7; from 1.1.0 before 1.1.6 — fixed in 1.0.7, 1.1.6
- Spring AI: from 1.0.0 before 1.0.7; from 1.1.0 before 1.1.6 — fixed in 1.0.7, 1.1.6
How to fix
Upgrade to a fixed version: Spring AI 1.0.7, 1.1.6; Spring AI 1.0.7, 1.1.6. Check the vendor advisory for mitigations.
References
- https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N&version=3.1
- https://spring.io/security/cve-2026-41712
Get alerted when CVE-2026-41712 or the next vulnerability affects your stack