What’s Vulnerable › Vulnerabilities

CVE-2026-41714: In Spring AMQP the RabbitConnectionFactoryBean.setUri("amqps://...") bypasses secure SSL setup, uses TrustEverythingTrustManager

Description

Applications that configure their broker connection via RabbitConnectionFactoryBean.setUri("amqps://...") without also calling setUseSSL(true) get TLS encryption with no certificate validation and no hostname verification. Affected versions: Spring AMQP 4.0.0 through 4.0.3; 3.2.0 through 3.2.10; 3.1.0 through 3.1.15; 2.4.0 through 2.4.17.

Affected products

How to fix

Upgrade to a fixed version: Spring AMQP 2.4.18, 3.1.16, 3.2.10.1, 4.0.3.1; Spring AMQP 4.0.3.1, 3.2.10.1, 3.1.16, 2.4.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41714 or the next vulnerability affects your stack