What’s Vulnerable › Vulnerabilities
CVE-2026-41715: Reactor Netty HTTP Client Leaks Credentials On Protocol Downgrade Redirect
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-522
Description
In specific scenarios involving HTTP redirects from a secure to an insecure endpoint, the Reactor Netty HTTP client may leak credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects. Affected versions: Reactor Netty 1.0.0 through 1.0.51; 1.1.0 through 1.1.35; 1.2.0 through 1.2.17; 1.3.0 through 1.3.5.
Affected products
- Spring Reactor Netty: from 1.0.0 before 1.0.52; from 1.1.0 before 1.1.36; from 1.2.0 before 1.2.17.1; from 1.3.0 before 1.3.15.1 — fixed in 1.0.52, 1.1.36, 1.2.17.1, 1.3.15.1
How to fix
Upgrade to a fixed version: Spring Reactor Netty 1.0.52, 1.1.36, 1.2.17.1, 1.3.15.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41715 or the next vulnerability affects your stack