What’s Vulnerable › Vulnerabilities
CVE-2026-41717: Spring Data MongoDB - SpEL Expression Injection via Annotated Query Parameter Binding
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-917
Description
Spring Data MongoDB contains a SpEL (Spring Expression Language) expression injection vulnerability. The issue occurs during parameter binding when a user-defined repository query method is annotated with @Query and utilizes a capture-all placeholder. Affected versions: Spring Data MongoDB 5.0.0 through 5.0.5; 4.5.0 through 4.5.11; 4.4.0 through 4.4.14; 4.3.0 through 4.3.16; 4.2.0 through 4.2.15; 4.1.0 through 4.1.14; 4.0.0 through 4.0.15; 3.4.0 through 3.4.19.
Affected products
- Spring Data MongoDB: from 3.4.0 before 3.4.20; from 4.0.0 before 4.0.16; from 4.1.0 before 4.1.15; from 4.2.0 before 4.2.16; from 4.3.0 before 4.3.17; from 4.4.0 before 4.4.15 — fixed in 3.4.20, 4.0.16, 4.1.15, 4.2.16, 4.3.17, 4.4.15
- Spring Data MongoDB: from 5.0.0 before 5.0.5.1; from 4.5.0 before 4.5.11.1; from 4.4.0 before 4.4.15; from 4.3.0 before 4.3.17; from 4.2.0 before 4.2.16; from 4.1.0 before 4.1.15 — fixed in 5.0.5.1, 4.5.11.1, 4.4.15, 4.3.17, 4.2.16, 4.1.15
How to fix
Upgrade to a fixed version: Spring Data MongoDB 3.4.20, 4.0.16, 4.1.15, 4.2.16; Spring Data MongoDB 5.0.5.1, 4.5.11.1, 4.4.15, 4.3.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41717 or the next vulnerability affects your stack