What’s Vulnerable › Vulnerabilities

CVE-2026-41721: Spring Data Commons Denial of Service via Data Binding

Description

Spring Data Commons contains a vulnerability that can lead to a Denial of Service (DoS) condition if Spring Data Web Support is enabled in conjunction with a Controller method using @ProjectedPayload, when an attacker sends a specially crafted HTTP request that causes the application to allocate lots of memory. Affected versions: Spring Data Commons 4.0.0 through 4.0.5; 3.5.0 through 3.5.11; 3.4.0 through 3.4.14; 3.3.0 through 3.3.16; 3.2.0 through 3.2.15; 3.1.0 through 3.1.14; 3.0.0 through 3.0.15; 2.7.0 through 2.7.19.

Affected products

How to fix

Upgrade to a fixed version: Spring Data Commons 2.7.20, 3.3.17, 3.4.15, 3.5.11.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41721 or the next vulnerability affects your stack