What’s Vulnerable › Vulnerabilities

CVE-2026-41731: In Spring for Apache Kafka, overly broad trusted-package matching in header mappers exposes JDK classes to deserialization

Description

JsonKafkaHeaderMapper and the deprecated DefaultKafkaHeaderMapper matched type headers against trusted packages using a prefix check, meaning that trusting any package implicitly trusted all of its subpackages. Combined with Jackson's default bean deserialization, a producer could supply crafted header values that caused the consumer to deserialize arbitrary JDK types. Affected versions: Spring for Apache Kafka 4.0.0 through 4.0.5; 3.3.0 through 3.3.15; 3.2.0 through 3.2.13; 2.9.0 through 2.9.13; 2.8.0 through 2.8.11.

Affected products

How to fix

Upgrade to a fixed version: Spring for Apache Kafka 2.8.12, 2.9.14, 3.2.14, 3.3.15.1; Spring for Apache Kafka 4.0.5.1, 3.3.15.1, 3.2.14, 2.9.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41731 or the next vulnerability affects your stack