What’s Vulnerable › Vulnerabilities
CVE-2026-41838: Spring Framework Predictable Session ID in WebSocket Module
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-330
Description
IDs for WebSocket sessions in the spring-websocket module are not cryptographically unpredictable, which may be possible to exploit in combination with inadequate authorization rules. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
Affected products
- Spring Framework: from 5.3.0 before 5.3.49; from 6.1.0 before 6.1.28; from 6.2.0 before 6.2.18.1; from 7.0.0 before 7.0.7.1 — fixed in 5.3.49, 6.1.28, 6.2.18.1, 7.0.7.1
- Spring Framework: from 7.0.0 before 7.0.7.1; from 6.2.0 before 6.2.18.1; from 6.1.0 before 6.1.28; from 5.3.0 before 5.3.49 — fixed in 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49
How to fix
Upgrade to a fixed version: Spring Framework 5.3.49, 6.1.28, 6.2.18.1, 7.0.7.1; Spring Framework 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41838 or the next vulnerability affects your stack