What’s Vulnerable › Vulnerabilities

CVE-2026-41839: Spring Framework Escalation via Session Fixation in WebFlux

Description

A WebFlux application with a compromised subdomain (for example, compromised via cross-site scripting (XSS)) is vulnerable to an escalation attack exchanging a known session ID for that of an authenticated user. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.3.49, 6.1.28, 6.2.19, 7.0.8; Spring Framework 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41839 or the next vulnerability affects your stack