What’s Vulnerable › Vulnerabilities

CVE-2026-41847: Spring Framework Security Filter Bypass in WebFlux Kotlin Router DSL

Description

Spring WebFlux applications may be vulnerable to a security bypass when using the Kotlin Router DSL. Affected versions: Spring Framework 5.3.0 through 5.3.48.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.3.49; Spring Framework 5.3.49. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41847 or the next vulnerability affects your stack