What’s Vulnerable › Vulnerabilities
CVE-2026-41849: Spring Framework Denial of Service via Integer Overflow in SpEL Expressions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-190
Description
An integer overflow vulnerability exists in the evaluation logic of the Spring Expression Language (SpEL). An attacker can exploit this by supplying a specially crafted SpEL expression that triggers excessive resource consumption, resulting in a Denial of Service (DoS). Affected versions: Spring Framework 5.3.0 through 5.3.48.
Affected products
- Spring Framework: from 5.3.0 before 5.3.49 — fixed in 5.3.49
- Spring Framework: from 5.3.0 before 5.3.49 — fixed in 5.3.49
How to fix
Upgrade to a fixed version: Spring Framework 5.3.49; Spring Framework 5.3.49. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41849 or the next vulnerability affects your stack