What’s Vulnerable › Vulnerabilities

CVE-2026-41851: Spring Framework Denial of Service via Unbounded Cache in SpEL

Description

Applications which accept user-supplied Spring Expression Language (SpEL) expressions may be vulnerable to a Denial of Service (DoS) attack if the evaluation of a SpEL expression triggers unbounded cache growth. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.3.49, 6.1.28, 6.2.18.1, 7.0.7.1; Spring Framework 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41851 or the next vulnerability affects your stack