What’s Vulnerable › Vulnerabilities
CVE-2026-41852: Spring Framework Arbitrary Method Invocation in SpEL Expressions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-863
Description
A vulnerability in Spring Expression Language (SpEL) evaluation logic allows for arbitrary zero-argument method invocation, even within restricted or read-only contexts, which may allow an attacker to invoke unintended application logic. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
Affected products
- Spring Framework: from 5.3.0 before 5.3.49; from 6.1.0 before 6.1.28; from 6.2.0 before 6.2.18.1; from 7.0.0 before 7.0.7.1 — fixed in 5.3.49, 6.1.28, 6.2.18.1, 7.0.7.1
- Spring Framework: from 7.0.0 before 7.0.7.1; from 6.2.0 before 6.2.18.1; from 6.1.0 before 6.1.28; from 5.3.0 before 5.3.49 — fixed in 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49
How to fix
Upgrade to a fixed version: Spring Framework 5.3.49, 6.1.28, 6.2.18.1, 7.0.7.1; Spring Framework 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41852 or the next vulnerability affects your stack