What’s Vulnerable › Vulnerabilities

CVE-2026-41853: Spring Framework Multipart Request Smuggling in Spring MVC and WebFlux

Description

Spring MVC and WebFlux applications are vulnerable to Multipart request smuggling attacks. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.3.49, 6.1.28, 6.2.18.1, 7.0.7.1; Maven Org.Springframework:Spring-Webflux 7.0.8, 6.2.19; Maven Org.Springframework:Spring-Webmvc 7.0.8, 6.2.19; Spring Framework 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41853 or the next vulnerability affects your stack