What’s Vulnerable › Vulnerabilities
CVE-2026-41857: BOSH CLI Shell Injection
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-10-25
- Weakness: CWE-78
Description
A compromised or malicious BOSH Director can execute arbitrary shell commands on the operator's workstation when the operator runs bosh ssh (or bosh scp/bosh logs -f) with default flags. Affected versions: BOSH CLI versions prior to 7.10.5.
Affected products
- CloudFoundry Foundation bosh-cli: before 7.10.5 — fixed in 7.10.5
How to fix
Upgrade to a fixed version: CloudFoundry Foundation bosh-cli 7.10.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41857 or the next vulnerability affects your stack