What’s Vulnerable › Vulnerabilities
CVE-2026-41860
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-04 · updated 2026-07-22
- Weakness: CWE-326
Description
CWE-326 in BOSH allows a local attacker to steal Basic-auth credentials or redirect UAA token requests via MITM. HttpRequestHelper#create_async_endpoint and #send_http_get_request_synchronous hard-code OpenSSL::SSL::VERIFY_NONE, enabling an attacker to intercept traffic between bosh-monitor and the BOSH director or UAA and steal credentials. Affected versions: - BOSH: all versions prior to v282.1.9 (inclusive); fixed in v282.1.9 or later
Affected products
- Cloud Foundry Foundation BOSH Director: before 282.1.9 — fixed in 282.1.9
How to fix
Upgrade to a fixed version: Cloud Foundry Foundation BOSH Director 282.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-41860 or the next vulnerability affects your stack