What’s Vulnerable › Vulnerabilities

CVE-2026-41862

Description

Spring Statemachine's Kryo-based persistence backends (JPA, MongoDB, Redis and ZooKeeper) deserialise persisted state-machine contexts without enforcing a class allowlist (CWE-502, deserialisation of untrusted data), which can lead to remote code execution inside the application JVM. Affected versions: Spring Statemachine 4.0.0 through 4.0.1 Spring Statemachine 3.2.0 through 3.2.4

Affected products

How to fix

Upgrade to a fixed version: Spring Statemachine 3.2.5, 4.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41862 or the next vulnerability affects your stack