What’s Vulnerable › Vulnerabilities

CVE-2026-41869: Apache Nutch: Unauthenticated forced shutdown and job interruption in Nutch Server (Nutch REST API)

Description

Missing Authorization, Improper Resource Shutdown and Job Interruption vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Nutch 1.23. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41869 or the next vulnerability affects your stack