What’s Vulnerable › Vulnerabilities
CVE-2026-41887: Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-26
- Weakness: CWE-22
Description
Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.
Affected products
- flarum framework: before 1.8.16; from 2.0.0-beta.1, < 2.0.0-rc.1
References
- https://github.com/flarum/framework/commit/2d90a1f19f0e46f8c7e1b07c48ba74b5e38f8410
- https://github.com/flarum/framework/releases/tag/v1.8.16
- https://github.com/flarum/framework/releases/tag/v2.0.0-rc.1
- https://github.com/flarum/framework/security/advisories/GHSA-xjvc-pw2r-6878
- https://github.com/flarum/framework/security/advisories/GHSA-xjvc-pw2r-6878
Get alerted when CVE-2026-41887 or the next vulnerability affects your stack