What’s Vulnerable › Vulnerabilities
CVE-2026-41908: OpenClaw < 2026.4.20 - Scope Enforcement Bypass in Assistant-Media Route
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.4.20 contains a scope enforcement bypass vulnerability in the assistant-media route that allows trusted-proxy callers without operator.read scope to access protected assistant-media files and metadata. Attackers can bypass identity-bearing HTTP auth path scope validation to retrieve sensitive media content within allowed media roots.
Affected products
- OpenClaw: before 2026.4.20 — fixed in 2026.4.20
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.20. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/99ef3a63c58440d53f8e45ad861b846032fcb036
- https://github.com/openclaw/openclaw/security/advisories/GHSA-v8qf-fr4g-28p2
- https://www.vulncheck.com/advisories/openclaw-scope-enforcement-bypass-in-assistant-media-route
Get alerted when CVE-2026-41908 or the next vulnerability affects your stack