What’s Vulnerable › Vulnerabilities
CVE-2026-41909: OpenClaw < 2026.4.20 - Improper Authorization in Paired-Device Pairing Actions
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.4.20 contains an improper authorization vulnerability in paired-device pairing management that allows limited-scope sessions to enumerate and act on pairing requests. Attackers with paired-device access can approve or operate on unrelated pending device requests within the same gateway scope.
Affected products
- OpenClaw: before 2026.4.20 — fixed in 2026.4.20
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.20. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/5a12f30441d5b0b151f550daa2c5c9e8db61e2e6
- https://github.com/openclaw/openclaw/security/advisories/GHSA-xrq9-jm7v-g9h7
- https://www.vulncheck.com/advisories/openclaw-improper-authorization-in-paired-device-pairing-actions
Get alerted when CVE-2026-41909 or the next vulnerability affects your stack