What’s Vulnerable › Vulnerabilities
CVE-2026-41912: OpenClaw < 2026.4.8 - Server-Side Request Forgery Policy Bypass via Interaction-Triggered Navigation
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-28 · updated 2026-06-17
- Weakness: CWE-918
Description
OpenClaw before 2026.4.8 contains a server-side request forgery policy bypass vulnerability allowing attackers to trigger navigations bypassing normal SSRF checks. Attackers can exploit browser interactions to bypass SSRF protections and access restricted resources.
Affected products
- OpenClaw: before 2026.4.8 — fixed in 2026.4.8
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vr5g-mmx7-h897
- https://www.vulncheck.com/advisories/openclaw-server-side-request-forgery-policy-bypass-via-interaction-triggered-navigation
Get alerted when CVE-2026-41912 or the next vulnerability affects your stack