What’s Vulnerable › Vulnerabilities
CVE-2026-41935: Vvveb < 1.0.8.3 Uncontrolled Recursion Denial of Service
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-26
- Weakness: CWE-209
Description
Vvveb before 1.0.8.3 contains an uncontrolled recursion vulnerability in the admin controller dispatch cycle where Base::init() repeatedly invokes permission() on error handlers, causing infinite recursion until PHP memory limits are exhausted. Attackers can send sustained requests to forbidden admin URLs from a low-privilege account to exhaust PHP memory on all workers and cause denial of service to legitimate traffic.
Affected products
- givanz Vvveb: before 1.0.8.3 — fixed in 1.0.8.3
How to fix
Upgrade to a fixed version: givanz Vvveb 1.0.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/givanz/Vvveb/commit/c766e84b479dcf1bd1f25a44e4b9c9fa450769c8
- https://github.com/givanz/Vvveb/releases/tag/1.0.8.3
- https://www.vulncheck.com/advisories/vvveb-uncontrolled-recursion-denial-of-service
Get alerted when CVE-2026-41935 or the next vulnerability affects your stack