What’s Vulnerable › Vulnerabilities
CVE-2026-41988
- Severity: low (CVSS 2.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-670
Description
uuid before 14.0.0 can make unexpected writes when external output buffers are used, and the UUID version is 3, 5, or 6. In particular, UUID version 4, which is very commonly used, is unaffected by this issue.
Affected products
- uuidjs uuid: before 11.1.1; 12.0.0, 13.0.0 — fixed in 11.1.1
How to fix
Upgrade to a fixed version: uuidjs uuid 11.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/uuidjs/uuid/commit/3d2c5b0342f0fcb52a5ac681c3d47c13e7444b34
- https://github.com/uuidjs/uuid/security/advisories/GHSA-w5hq-g745-h8pq
- https://github.com/uuidjs/uuid/security/advisories/GHSA-w5hq-g745-h8pq
Get alerted when CVE-2026-41988 or the next vulnerability affects your stack