What’s Vulnerable › Vulnerabilities

CVE-2026-41989

Description

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

Affected products

How to fix

Upgrade to a fixed version: gnupg Libgcrypt 1.10.4, 1.11.3, 1.12.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-41989 or the next vulnerability affects your stack