What’s Vulnerable › Vulnerabilities
CVE-2026-41990
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-10-26
- Weakness: CWE-787
Description
Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.
Affected products
- gnupg Libgcrypt: from 1.12.0 before 1.12.2 — fixed in 1.12.2
How to fix
Upgrade to a fixed version: gnupg Libgcrypt 1.12.2. Check the vendor advisory for mitigations.
References
- https://dev.gnupg.org/T8208
- https://lists.gnupg.org/pipermail/gnupg-announce/2026q2/000503.html
- https://www.openwall.com/lists/oss-security/2026/04/21/1
Get alerted when CVE-2026-41990 or the next vulnerability affects your stack