What’s Vulnerable › Vulnerabilities
CVE-2026-42007
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-03
- Weakness: CWE-416
Description
An attacker that has valid credentials can use a Sieve script with the editheader extension to trigger a use-after-free in the mail editing code, and to write memory contents beyond the intended buffer into the delivered mail. This causes memory leak and opportunity to do memory corruption during mail delivery, which can crash the delivery process and may allow execution of arbitrary code in the context of that process. Disable the Sieve editheader extension. Update to non-vulnerable version. No publicly available exploits are known.
Affected products
- Open-Xchange GmbH OX Dovecot CE: from 2.3.0 before 2.4.5 — fixed in 2.4.5
- Open-Xchange GmbH OX Dovecot Pro: from 2.3.0 before 2.3.22.2; from 3.0.0 before 3.0.7; from 3.1.0 before 3.1.6 — fixed in 2.3.22.2, 3.0.7, 3.1.6
How to fix
Upgrade to a fixed version: Open-Xchange GmbH OX Dovecot CE 2.4.5; Open-Xchange GmbH OX Dovecot Pro 2.3.22.2, 3.0.7, 3.1.6. Check the vendor advisory for mitigations.
References
- https://documentation.open-xchange.com/dovecot/security/advisories/csaf/2026/oxdc-adv-2026-0003.json
Get alerted when CVE-2026-42007 or the next vulnerability affects your stack