What’s Vulnerable › Vulnerabilities
CVE-2026-42009: Gnutls: gnutls: denial of service via dtls packet reordering vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-18 · updated 2026-10-30
- Weakness: CWE-475
Description
A flaw was found in gnutls. A remote attacker could exploit an issue in the Datagram Transport Layer Security (DTLS) packet reordering logic. The comparator function, responsible for ordering DTLS packets by sequence numbers, did not correctly handle packets with duplicate sequence numbers. This could lead to unstable packet ordering or undefined behavior, resulting in a denial of service.
Affected products
- [UNKNOWN] gnutls: all versions
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0, 9.8, 10.0 (+1) (and their updates)
- RedHat Enterprise Linux For Els: 8.10, 9.8, 10.2 (and their updates)
- RedHat Enterprise Linux For Eus: 9.8, 10.2 (and their updates)
- RedHat Enterprise Linux For Ibm Z Systems: 8.0_s390x, 9.0_s390x, 10.2 (and their updates)
- RedHat Enterprise Linux For Ibm Z Systems Els: 8.10, 9.8, 10.2 (and their updates)
- RedHat Enterprise Linux For Ibm Z Systems Eus: 9.8, 10.2 (and their updates)
- RedHat Enterprise Linux For Power Little Endian: 8.0_ppc64le, 9.0_ppc64le, 10.0, 10.2 (and their updates)
- RedHat Enterprise Linux For Power Little Endian Els: 8.10, 9.8, 10.2 (and their updates)
- RedHat Enterprise Linux For Power Little Endian Eus: 9.8, 10.2 (and their updates)
- RedHat Enterprise Linux For Update Services For Sap Solutions: 9.8 (and their updates)
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 9.8 (and their updates)
- RedHat Hardened Images: all versions
- Red Hat OpenShift Container Platform 4.18: 4.0 (and their updates)
- [UNKNOWN] gnutls: before 3.8.13 — fixed in 3.8.13
- Red Hat Cert Manager support for Red Hat OpenShift release 1.17: all versions — fixed in 1791371080
- Red Hat Cert Manager support for Red Hat OpenShift release 1.18: all versions — fixed in 1791459707
- Red Hat Cert Manager support for Red Hat OpenShift release 1.20: all versions — fixed in 1790598593
- Red Hat OpenShift Container Platform 4.18: all versions — fixed in 418.94.202608142238-0
- Red Hat AI Inference Server 3.2: all versions — fixed in 1782951051
- Red Hat Discovery 2: all versions — fixed in 1782159791
- Red Hat Enterprise Linux 10: all versions — fixed in 0:3.8.10-4.el10_2
- Red Hat Enterprise Linux 10.0 Extended Update Support: all versions — fixed in 0:3.8.9-9.el10_0.19
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:3.3.29-9.el7_9.1
- Red Hat Enterprise Linux 8: all versions — fixed in 0:3.6.16-8.el8_10.6
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:3.6.14-10.el8_4.1
- Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: all versions — fixed in 0:3.6.14-10.el8_4.1
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:3.6.16-5.el8_6.5
- Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On: all versions — fixed in 0:3.6.16-5.el8_6.5
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 0:3.6.16-7.el8_8.4
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.8.13; Red Hat Cert Manager support for Red Hat OpenShift release 1.17 1791371080; Red Hat Cert Manager support for Red Hat OpenShift release 1.18 1791459707; Red Hat Cert Manager support for Red Hat OpenShift release 1.20 1790598593; Red Hat OpenShift Container Platform 4.18 418.94.202608142238-0; Red Hat AI Inference Server 3.2 1782951051; Red Hat Discovery 2 1782159791; Red Hat Enterprise Linux 10 0:3.8.10-4.el10_2; Red Hat Enterprise Linux 10.0 Extended Update Support 0:3.8.9-9.el10_0.19; Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:3.3.29-9.el7_9.1; Red Hat Enterprise Linux 8 0:3.6.16-8.el8_10.6; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:3.6.14-10.el8_4.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:13274
- https://access.redhat.com/errata/RHSA-2026:20611
- https://access.redhat.com/errata/RHSA-2026:20612
- https://access.redhat.com/errata/RHSA-2026:20613
- https://access.redhat.com/errata/RHSA-2026:26319
- https://access.redhat.com/errata/RHSA-2026:26409
- https://access.redhat.com/errata/RHSA-2026:29197
- https://access.redhat.com/errata/RHSA-2026:29794
- https://access.redhat.com/errata/RHSA-2026:30004
- https://access.redhat.com/errata/RHSA-2026:30849
- https://access.redhat.com/errata/RHSA-2026:30850
- https://access.redhat.com/errata/RHSA-2026:32962
Get alerted when CVE-2026-42009 or the next vulnerability affects your stack