What’s Vulnerable › Vulnerabilities
CVE-2026-42048: Langflow: Path Traversal in Langflow Knowledge Bases API
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-12 · updated 2026-06-17
- Weakness: CWE-22
Description
Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.0, Langflow is vulnerable to Path Traversal in the Knowledge Bases API (DELETE /api/v1/knowledge_bases). This occurs because user-supplied knowledge base names are concatenated directly into file paths without proper sanitization or boundary validation. An authenticated attacker can exploit this flaw to delete arbitrary directories anywhere on the server's filesystem, leading to data loss and potential service disruption. This vulnerability is fixed in 1.9.0.
Affected products
- IBM Langflow OSS: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-9whx-c884-c68q
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-9whx-c884-c68q
Get alerted when CVE-2026-42048 or the next vulnerability affects your stack