What’s Vulnerable › Vulnerabilities
CVE-2026-42055: NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-09-14
- Weakness: CWE-122
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules. This vulnerability exists when the proxy_http_version to 2 or grpc_pass directives are used to proxy HTTP/2 traffic, the ignore_invalid_headers directive is set to off, and the large_client_header_buffers directive size is larger than 2 megabytes. A remote, unauthenticated attacker, along with conditions beyond their control, could send large headers while creating an upstream request. This may cause a heap-based buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 Dos: from 4.3.0 through 4.7.0; 4.9.0
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 through 2.6.3
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 4.0.0 through 4.0.1; from 5.0.0 through 5.5.0
- F5 NGINX Instance Manager: from 2.17.0 through 2.22.0
- F5 NGINX Open Source: from 1.0.0 through 1.30.2; from 1.31.0 through 1.31.1
- F5 NGINX Plus: from 37.0.0.1 before 37.0.2.1; from r33 before r36; r36, r36-p1, r36-p2, r36-p3, r36-p4, r36-p5 — fixed in 37.0.2.1, r36
- F5 Waf: from 4.10.0 through 4.16.0; from 5.2.0 through 5.8.0; from 5.9.0 through 5.13.1
- RedHat Discovery: all versions
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Hardened Images: all versions
- RedHat Update Infrastructure: from 5.0 before 5.2 — fixed in 5.2
How to fix
Upgrade to a fixed version: F5 NGINX Plus 37.0.2.1, r36; RedHat Update Infrastructure 5.2. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000161584
- https://access.redhat.com/errata/RHSA-2026:27197
- https://access.redhat.com/errata/RHSA-2026:36331
- https://access.redhat.com/errata/RHSA-2026:36364
- https://access.redhat.com/errata/RHSA-2026:36618
- https://access.redhat.com/errata/RHSA-2026:36639
- https://access.redhat.com/errata/RHSA-2026:38847
- https://access.redhat.com/errata/RHSA-2026:44481
- https://access.redhat.com/errata/RHSA-2026:46836
- https://access.redhat.com/errata/RHSA-2026:58981
- https://access.redhat.com/security/cve/CVE-2026-42055
- https://bugzilla.redhat.com/show_bug.cgi?id=2489866
Get alerted when CVE-2026-42055 or the next vulnerability affects your stack