What’s Vulnerable › Vulnerabilities
CVE-2026-42076: Evolver: Command Injection via `execSync` in `_extractLLM()` function allows Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-78
Description
Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.
Affected products
- EvoMap evolver: before 1.69.3
References
- https://github.com/EvoMap/evolver/releases/tag/v1.69.3
- https://github.com/EvoMap/evolver/security/advisories/GHSA-j5w5-568x-rq53
- https://github.com/EvoMap/evolver/security/advisories/GHSA-j5w5-568x-rq53
Get alerted when CVE-2026-42076 or the next vulnerability affects your stack