What’s Vulnerable › Vulnerabilities
CVE-2026-42089: yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-10-25
- Weakness: CWE-829
Description
Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.
Affected products
- yeoman environment: from 2.9.0, < 6.0.1
References
- https://github.com/yeoman/environment/commit/78d2af7e60294784b8a8b3b3b5099c6874b6a1fa
- https://github.com/yeoman/environment/pull/753
- https://github.com/yeoman/environment/security/advisories/GHSA-vv9j-gjw2-j8wp
Get alerted when CVE-2026-42089 or the next vulnerability affects your stack