What’s Vulnerable › Vulnerabilities
CVE-2026-42137: Kirby: `pages.access/list` and `files.access/list` permissions are not consistently checked in the REST API and changes dialog
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-862
Description
Kirby is an open-source content management system. Prior to versions 4.9.0 and 5.4.0, `pages.access/list` and `files.access/list` permissions are not consistently checked in the Panel and REST API. This issue has been patched in versions 4.9.0 and 5.4.0.
Affected products
- getkirby kirby: before 4.9.0; from 5.0.0 before 5.4.0 — fixed in 4.9.0, 5.4.0
How to fix
Upgrade to a fixed version: getkirby kirby 4.9.0, 5.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/getkirby/kirby/releases/tag/4.9.0
- https://github.com/getkirby/kirby/releases/tag/5.4.0
- https://github.com/getkirby/kirby/security/advisories/GHSA-85x2-r8xv-ww8c
Get alerted when CVE-2026-42137 or the next vulnerability affects your stack